Announcement

Collapse
No announcement yet.

Performance issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Performance issues

    Hey everybody. Just bought the game from the GOG store. Everything is running fine, at a solid 60 fps 90% of the time. But here's the problem: in almost every map/location of the game there's a certain spot, if I look in a certain direction, there's a frame rate drop, down to almost 20-30 fps. What gives? My rig is not top of the line by current standards but is nowhere near a bad one that it couldn't possibly run this game flawlessly:
    AMD Athlon X4 760k (quad core)
    AMD R9 270X
    4GB RAM
    Windows 10

    Any help would be appreciated.

  • #2
    Where there are more objects to render in a certain location, the game will need more power in certain spots. Maybe this is the case here. But your fps drops are very unusual and extreme, so I'm not sure.

    Tried the standard stuff? Update Drivers, reinstall/repair game, tried lowering graphics settings?
    I've put the Imagination in its Place.

    Comment


    • #3
      Originally posted by LSKzane View Post
      Tried the standard stuff? Update Drivers, reinstall/repair game, tried lowering graphics settings?
      Yes, drivers up to date, all settings set to "use application settings" in AMD Control Panel, tried everything.

      Comment


      • #4
        Can you take a screenshot of what you're looking at when performance drops?

        Comment

        Working...
        X