Announcement

Collapse
No announcement yet.

Weird mouse pointer behaviour on menu screens

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PC Weird mouse pointer behaviour on menu screens

    Hi,

    So I installed Alan Wake Collector's Edition for the first time a few days ago on my notebook PC. The game itself runs fine and is very impressive, but when I'm on the menu screen (either when paused or before starting a game) the mouse pointer behaves very strangely. The pointer itself is offset about 2 inches up and to the left of the actual point being selected, so menu items are greyed out when you hover over them and highlighted when the pointer is a couple of inches away. If I move the pointer all the way to the bottom of the screen and click, it has the same effect as Alt-TABbing out of the game.

    I've done some playing around with menu options and this only happens when at 1600x900 resolution in fullscreen mode, which unfortunately is the exact mode in which it runs best for me. Different resolutions are fine in fullscreen mode, and 1600x900 in windowed mode works just fine also.

    I've tried unplugging the mouse and the problem remains if I use the touchpad instead, so doesn't appear to be linked to the mouse itself.

    Any suggestions? I'm not holding my breath for a patch to fix this, as I realise this game is 5+ years old now. While not exactly a gamebreaker, it does take the shine off what is otherwise an exceptionally decent PC port.

    My spec:

    ASUS N551JX notebook computer
    Intel i5 dual core processor
    8GB RAM
    Windows 8.1
    NVIDIA GTX 950m graphics with 2GB RAM

    Thanks for reading!




  • #2
    Is there any way you can test the game with the touchpad disabled?

    Comment


    • #3
      My touchpad is already set to auto-disable when a mouse is plugged in.

      Thing is, if it was a conflict of some sort between touchpad and mouse, why is it only affecting that one specific resolution? Strange. Also, I can't find anyone else out there reporting the same issue, which is even stranger.

      One thing I haven't tried yet is updating graphics drivers, as the ones I'm using were OEM-provided and may be somehow customized for my computer. Given that the computer came out 3 years after the game did, I doubt newer drivers are going to solve the problem.

      Comment


      • #4
        Could you give some specs on the screen you're using? Size, native resolution, refresh rate, etc. does the problem persist if you use an external screen option?

        Comment


        • #5
          You can try enabling "Disable display scaling on high DPI settings" by going into Alan Wake Collector Edition's folder and finding the actual Alan Wake.exe, right-clicking on it and choosing properties. The option should be located under compatibility.
          We are what we choose to be, not what we want to be

          Comment


          • #6
            Originally posted by Zhinarkos View Post
            You can try enabling "Disable display scaling on high DPI settings" by going into Alan Wake Collector Edition's folder and finding the actual Alan Wake.exe, right-clicking on it and choosing properties. The option should be located under compatibility.
            Thanks Zhinarkos, that worked! Ironically, I was tinkering with that option a few days ago to try and fix issues in another game, never thought to try it on Alan Wake.

            Comment


            • #7
              No problem, I'm glad the problem got fixed so easily.
              We are what we choose to be, not what we want to be

              Comment

              Working...
              X