Announcement

Collapse
No announcement yet.

Alan Wake sudden frame rate drop ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alan Wake sudden frame rate drop ?

    Out of nowhere, suddenly I experiance constant frame drops. I have a high-end PC and I never had problems with Alan Wake running butter smooth on max settings. I tried different nVidia drivers, odler ones and ect. Nothing helps. All other games run just fine.

    I wonder if it has something to do with Windows 10 update or there has been a little update for Alan Wake I am not aware of ?

  • #2
    As far as I know the game hasn’t changed. Is your system getting hot?

    Comment


    • #3
      It seems the problem is with the last 2 Windows 10 updates. Frame drops (for Alan Wake only) started right after the first update.
      Last edited by thermos; 01-17-2019, 03:27 PM.

      Comment


      • #4
        Update. It seems latest nVidia drivers are the issue (417). Instead of 120+ FPS I get roughly 40 FPS on GTX 1080

        Comment


        • #5
          I just recently installed Win 10 Pro 64-bit build 1809 on a new computer. Just tried AW and have zero issues. Maxed out all settings with no drops at all so far. I played from beginning until lovers peak.

          Im also using using driver 419.35. You still have issues?
          ASUS MAXIMUS XI CODE, Intel i9-9900K 4.7GHz
          32GB G.SKILL DDR4 32000MHz, EVGA GTX 1080Ti SLI
          WD BLACK 1TB NVMe, Win 10 64-bit Pro

          Comment


          • #6
            Yup, issue still persists with 417.71. Thought I may try 419.35 and see if anything changes.

            The wierd part is, the only game affected is Alan Wake o_o

            Comment


            • #7
              Maybe try the generic things? Verify Integrity? Reinstall AW? I have noticed that using DDU with Win 10 is really good for removing NVIDIA drivers before you update. It really cleans out the system well and I would recommend. Have you tried that?

              Heres a link: https://www.wagnardsoft.com/
              ASUS MAXIMUS XI CODE, Intel i9-9900K 4.7GHz
              32GB G.SKILL DDR4 32000MHz, EVGA GTX 1080Ti SLI
              WD BLACK 1TB NVMe, Win 10 64-bit Pro

              Comment


              • #8
                Something I've had success with, is rolling drivers back to previous versions that were incredibly stable. When I recently tried to play a year old title (Far Cry 5), I found that the latest drivers were causing horrible graphical glitches and crashes. So, I rolled back to one I had on my system (I keep notes, sometimes) that worked well for a lot of games that came out during that time. Version 392.88 fixed it right up. Cutscenes were smooth, no more smeared, blurry looking textures, no more crashes.

                They are still installed, since I've gone back and played several older titles lately, and they still work great with current-ish titles too, like Call of Cthulhu (the new one from Oct 2018, not the Dark Corners of the Earth).

                Switching drivers is quite easy, so I don't mind testing out different ones with games. AFAIK this 392.88 Nvidia driver version works great with Alan Wake. No issues so far, and I'm in Episode 2 right now.

                (I have Windows 10, 64-bit with all the latest updates.)
                Last edited by EbonHawk; 04-26-2019, 04:23 PM. Reason: added info

                Comment


                • #9
                  I haven't really tried older drivers with freshly installed Windows 10. I must say the latest nVidia drivers do a little better but still not good enough. Some other softwares require latest nVidia drivers for GPU acceleration so... Other than that I find it funny that Alan Wake is the only game with frame rate under 60. It was around 180 before ( 1440p Max settings ).

                  Comment

                  Working...
                  X