Announcement

Collapse
No announcement yet.

Gaining access to the WindowsApps Folder?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gaining access to the WindowsApps Folder?

    Anyone know how to gain access to the WindowsApps folder on a "secondary drive"? (Windows 10)

    I have found its possible if its installed on your local disk "C" - Not on a secondary drive for some reason.

    Anyone?
    Last edited by Djsmoov; 04-15-2016, 04:54 AM.

  • #2
    I assume that the steps needed to gain access to that folder are the same no matter what drive it has been moved to. Basically what you need to do is go to the Folder options in the explorer, untick "Hide protected system files/folders" and tick "Show hidden files/folders" (or something like that, I don't recall precisely). Then you should be able to see the folder in the file explorer. I think it should be X:\WindowsApps\ where X stands for the letter of the drive where you moved the installation folder to. To access it's contents you need to take ownership of said folder. However there's a risk of a major fuckup if you don't absolutely understand what are you doing, so I'd rather not delve into details.

    Comment


    • #3
      Taking ownership only seems to work if the game is installed on the primary drive - C:\WindowsApps - Windows 10 that is.

      I cannot access the folder at all. Not even to add quantumbreak.exe to the NVIDIA control panel or even change the priority in the task manager.

      The windows store is an absolute piece of @#%$^%$%^$%^$%#!!!!

      Comment


      • #4
        To gain access to the Microsoft Apps folder....
        Right click on the folder, go to Properties.
        From there, click on "Security" and then click "Advanced"

        From there, click on "Change"...


        After clicking that, it will bring up the "Select User or Group" window.
        Towards the bottom there will be a spot to enter your administrator name. Enter your PC's name (in my case) CHARON\*admin name*

        Click "OK"

        You will be back at the previous window, and the "owner" of this folder will have changed from "trustedinstaller" to your admin name.
        Directly under "owner" is a checkbox with "Replace owner on sub containers and objects" next to it. Make sure to click that.

        Click "OK"

        It will take a bit to switch the permissions of everything in the Apps folder to you, so give it a bit. And that's it.
        You can now browse this folder to your hearts content.

        Comment


        • #5
          Damien_Azreal, switch This only works for the "C" drive. Try it If [SIZE=16px]WindowsApps Folder is [/SIZE]relocated.

          Comment


          • #6
            Originally posted by Djsmoov View Post
            Taking ownership only seems to work if the game is installed on the primary drive - C:\WindowsApps - Windows 10 that is.

            I cannot access the folder at all. Not even to add quantumbreak.exe to the NVIDIA control panel or even change the priority in the task manager.

            The windows store is an absolute piece of @#%$^%$%^$%^$%#!!!!


            I installed qb on station D, not in C.
            I also can't find qb in the nvidia configuration screen to change the 3D settings to the nvidia gpu.

            Heres maybe a fix:
            Go to search in windows, and search:
            powershell

            Fill in: [FONT=myriad-pro][SIZE=14px]Get-AppxPackage Microsoft.QuantumBreak
            then hit enter.

            Then you see where the QB folder is. In my case it was in C, while i installed QB in station D.
            Then copy that files name: C;xxxxxxxxxxxxxxxxx and go to Nvidia configuration screen, 3D settings, then to add program, paste that files name over there and it's in Nvidia.[/SIZE][/FONT]
            Last edited by globalhalopro4u; 04-14-2016, 05:42 PM.

            Comment


            • #7
              Nope still NO luck!!!!!
              Tried everything - Taking ownership of the WindowsApps folder via the "Security" tab in drive "C" works fine - and this is the Only drive it works on.

              When QB is installed on any other drive, the WindowsApps folder isn't even hidden. The QuantumBreak.exe file cannot even be accessed in the task manager when its not installed in its default location.

              The windows store is a broken pile of @##%! Cant even believe u don't have control where u want the game to install!!!!!!!!!!!!!!!!!

              CANT FIND A FIX FOR THIS ANYWHERE!
              Last edited by Djsmoov; 04-15-2016, 04:53 AM.

              Comment


              • #8
                I am having the same exact issue here. Taking ownership of C:\Program Files\WindowsApps works as expected, but when you install apps on another drive/partition other than C:, Win10 will not process the permissions correctly, resulting in not allowing you access to the folder.

                Found a neat program that allows backup and restoring Win 10 apps/games, but I need access the DIR to get it going....

                Comment


                • #9
                  Well, you can access it from safe mode, but not during normal boot....

                  Even added my userprofile to Full Access permissions; not just ownership, still cannot access it under normal boot.

                  Comment


                  • #10
                    Solved....

                    Must enable built-in administrator account, "Super Admin". Folders are accessible afterwards........

                    Comment


                    • #11
                      Originally posted by MaximusX800 View Post
                      Solved....

                      Must enable built-in administrator account, "Super Admin". Folders are accessible afterwards........
                      How do I enable Super admin?

                      Comment


                      • #12
                        Originally posted by Djsmoov View Post

                        How do I enable Super admin?

                        This is simply the built-in Administrator account that is normally disabled by MS. However, it seems even those file browsing from these folders is allowed, there are limitations of this profile, to once again, keep your system secure. Old viruses would attach into this account to take control.

                        Side note: using a sub explorer, you can access them from your normal account, but not by normal browsing. I wonder if you create the folder first, what would happen....

                        I really don't want to have to re-download 100+GB of Win 10 Games.....

                        Comment


                        • #13
                          Sorry for bringing up such old topic, but I have useful information.

                          I succesfully moved WindowsApps folder by NTFS Access, Take Ownership, and in case of removing (or renaming - faster) WindowsApps - Unlocker (or restart).

                          But... The game won't launch after such copying. It will show up an error in MS Store. At least I tried with game installed on D: (drive letters during the processs were preserved all the time)
                          Other error about plugging in old drive shows up when you moved game files which were in state of downloading.

                          So the only way to move the folder is Windows Settings.

                          I recommend this method of downloading MS Store games. You just end up with one file to install, with posibility to store it:
                          https://translate.google.pl/translat...tml&edit-text=
                          You won't have to re-download the game all the time, e.g. in case of formatting system, etc.
                          Even in case of error 0x80073d0b during moving game in Windows Settings. It was useful to me at least once so far.

                          Comment

                          Working...
                          X