Announcement

Collapse
No announcement yet.

Chapter 2 Can't pick up Chronon Source / Bug. Please help!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chapter 2 Can't pick up Chronon Source / Bug. Please help!

    I can't pick up the Chronon Source on the floor of the abandoned building (the one next to where the gate control is for you and Amy to pass to the trainyard).

    I know you need to drop down into the building after walking atop the training, scaffolding, and roof. Getting in is ok, but there's no command whatsoever to collect it.
    I'm absolutely loving the game, but this is literally hindering me from continuing for almost 3 days now since I wanted to reach 100%.
    Please help.

    Image of the place/Chronon in question:
    http://imgur.com/a/Z65tV

  • #2
    Hey TNT4THEBRAIN, welcome to the forums!

    I remember seeing a topic like this on the Steam discussion boards for the game. I'm guessing you're Diao Bombsky? Did you try Lexrizi's suggestion in the end? I know you had some questions that haven't been answered yet.

    From the screenshot it looks like you just met Amy again near the tracks? If you restart the checkpoint, you should only be replaying the past minute or two. There's a checkpoint just as you leave the building and she points out the security station on the other side. It does mean that you would have to replay the gate section, but reloading shouldn't send you back any further than entering the area.
    The Sudden Stop - Remedy Fansite

    Comment


    • #3
      Hi Jaden! Thank you so much for replying.
      I'm indeed the one and only Diao Didn't have much luck with solutions there, so I thought I'd try it out here. So I truly appreacite your answer!
      I tried Lexrizi's hunch but it didn't work. I can get the other 2 Chronum that are also in the trainyard perfectly, the only one I can't is this one.
      I have tried realoding this checking with Amy near the tracks tracks for about 5 times now. And it just doesn't become available =/
      I have been thinking about just restarting chapter 2 entirely over, and then not 'analysing/scanning' but afraid it won't work and that I'll just end up doing everything again for nothing. But there doesn't seem to be a way out if it
      I searched google for it and apparently people have this problem on other locations/Chronon Sources as well, all a bit random. May I ask if there are any hunches why this is happening?

      Comment


      • #4
        It's nice to have you on these forums too, although I wish it was under better circumstances.

        For capturing difficult Chronon Sources, the two main tips seem to be restarting the checkpoint or restarting the act. For your position in that level, it would either be two minutes or ten minutes. I don't know if restarting the act would unlock it, but it's something which has been used to get around the issue with a lot of success. I'll definitely keep looking though and let you know as soon as I found something.

        As for hunches, I don't work for Remedy (I just do forum moderating in my space time), so unfortunately I don't know if I can provide any useful information in that regard. Hopefully we can find something so you do find a way to collect it though.
        The Sudden Stop - Remedy Fansite

        Comment

        Working...
        X