Announcement

Collapse
No announcement yet.

Chapter 2 Ground Zero, cannot pick up Chronon source in front of graffiti

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chapter 2 Ground Zero, cannot pick up Chronon source in front of graffiti

    As title. I see it, it's in the abandonned place with the elephant graffiti. I tried multiple angles, hopping on the platform, nothing.

    I also tried restarting the checkpoint as well as verifying the game files on steam, still nothing. I'm a bit of a completionist and this is the sort of thing that nags at my mind and makes me want to stop right there until I can solve it. Any help would be really appreciated.

  • #2
    Worse comes to worse Iím pretty certain that starting a new profile on a new save should fix the issue but Iím not exactly clear what you might have done to trigger the issue.

    Can you describe more about how you played the level?

    Comment


    • #3
      Played the level? Not sure how I can really answer that.. I used my time powers a lot, favor the heavy pistol and advanced SMG. I arrive at the sealed door lab, kill the two guards, make for the right and try to grab the chronon source but there's no prompt to actually take it. First chronon source I see doing that too, I picked every other before.

      Comment


      • #4
        Have you seen any recent walkthrough? Perhaps you collected it, died and it respawned? Did you die at any point before collecting it?

        Comment


        • #5
          No, I just got there and did not move any further as I couldn't collect it. Chronon sources disappear unlike the other items.

          Comment

          Working...
          X